Sync Performance Impacted
Incident Report for Formstack Sync
Resolved
This incident has been resolved and Syncs should be back to expected performance.
Posted Sep 25, 2020 - 20:33 UTC
Monitoring
We have identified an issue that negatively impacts Sync performance such that Syncs are running slower than expected and having a longer delay between sync runs than expected.

We have implemented a fix and are monitoring to confirm improvement.
Posted Sep 25, 2020 - 16:35 UTC
This incident affected: Formstack Sync Core Services.