Third Party Billing Services
Incident Report for Formstack Sync
Resolved
Details of this incident can be viewed at https://trust.zuora.com/.
Posted Aug 24, 2020 - 17:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2020 - 14:54 UTC
Identified
A third party dependency for our billing profiles is currently experiencing intermittent issues. You may experience issues with viewing or updating your current billing information.

You may monitor this issue directly from the vendor here: https://trust.zuora.com/

You may also use this form to submit updates to our billing team directly: https://formstackhq.formstack.com/forms/profileupdate
Posted Aug 24, 2020 - 13:40 UTC
This incident affected: Third Party (Billing Services).